I will look at this more closely, Nandi. I am learning these details myself. You can use Linux GUI gparted command to view the disk partition.
sudo fdisk -l
sudo gdisk /dev/sda or sudo gdisk /dev/sdb
print
https://forums.FreeBSD.org/threads/wha ... ost-583240
Oct 3, 2022 _Martin says:
Actually yesterday I realized that boot1.efi is important part of my desktop/dev setup. One of my disks is shared between Linux and FreeBSD. I'm using grub, FreeBSD is chainloaded from it. I can't chainload loader.efi, it as to be boot1.efi. So this file is very important in this setup.
https://github.com/tianocore/tianocore. ... /wiki/UEFI
https://uefi.org/ UEFI org information
FreeBSD commands:
camcontrol devlist
geom disk list
gpart status
gpart show -lp
efibootmgr -o
Will update when I have more knowledge. Assume /dev/da0 is your booting GhostBSD image disk. Could be /dev/ada0 /dev/da1 or other name.
su -
mkdir /mnt/esp
mkdir /mnt/rootfs
mount_msdosfs /dev/da0p1 /mnt/esp
pkg install tree
tree /mnt/esp
What every is in the /EFI/BOOT directory is the default bootloader.EFI image that the GPT UEFI BIOS selects to default boot image.
/EFI/BOOT/BOOTX64-REFIND.EFI is the refind boot manager image
/EFI/refind /BOOTX64-REFIND.EFI is the refind bootloader files location
/EFI/refind/icons Icon png images for many different operating systems
/EFI/mxlinux/BOOTX64-mxlinux.efi
/EFI/ghostbsd/BOOTX64_GHOSTBSD.EFI
the UEFI BIOS (not MBR BIOS) works with scheme GPT partitioned disk example command (gpart create -S GPT /dev/da1)
The GPT UEFI BIOS, will find the first ESP EFI FAT32 primary partition and then find either the /EFI/BOOT/bootx64_xyza.EFI
https://wiki.freebsd.org/UEFI WIKI on FreeBSD UEFI
https://freebsdfoundation.org/freebsd-uefi-secure-boot/ FreeBSD Foundation article on UEFI secure boot setup
https://forums.freebsd.org/threads/what ... for.86466/ What are all those EFI binaries?
https://forums.FreeBSD.org/threads/what ... ost-583240 _Martin comment Oct 8, 2022
sudo fdisk -l
sudo gdisk /dev/sda or sudo gdisk /dev/sdb
https://forums.FreeBSD.org/threads/wha ... ost-583240
Oct 3, 2022 _Martin says:
Actually yesterday I realized that boot1.efi is important part of my desktop/dev setup. One of my disks is shared between Linux and FreeBSD. I'm using grub, FreeBSD is chainloaded from it. I can't chainload loader.efi, it as to be boot1.efi. So this file is very important in this setup.
https://github.com/tianocore/tianocore. ... /wiki/UEFI
https://uefi.org/ UEFI org information
FreeBSD commands:
camcontrol devlist
geom disk list
gpart status
gpart show -lp
efibootmgr -o
Will update when I have more knowledge. Assume /dev/da0 is your booting GhostBSD image disk. Could be /dev/ada0 /dev/da1 or other name.
su -
mkdir /mnt/esp
mkdir /mnt/rootfs
mount_msdosfs /dev/da0p1 /mnt/esp
pkg install tree
tree /mnt/esp
What every is in the /EFI/BOOT directory is the default bootloader.EFI image that the GPT UEFI BIOS selects to default boot image.
/EFI/BOOT/BOOTX64-REFIND.EFI is the refind boot manager image
/EFI/refind /BOOTX64-REFIND.EFI is the refind bootloader files location
/EFI/refind/icons Icon png images for many different operating systems
/EFI/mxlinux/BOOTX64-mxlinux.efi
/EFI/ghostbsd/BOOTX64_GHOSTBSD.EFI
the UEFI BIOS (not MBR BIOS) works with scheme GPT partitioned disk example command (gpart create -S GPT /dev/da1)
The GPT UEFI BIOS, will find the first ESP EFI FAT32 primary partition and then find either the /EFI/BOOT/bootx64_xyza.EFI
https://wiki.freebsd.org/UEFI WIKI on FreeBSD UEFI
https://freebsdfoundation.org/freebsd-uefi-secure-boot/ FreeBSD Foundation article on UEFI secure boot setup
https://forums.freebsd.org/threads/what ... for.86466/ What are all those EFI binaries?
https://forums.FreeBSD.org/threads/what ... ost-583240 _Martin comment Oct 8, 2022
Statistics: Posted by wb7odyfred — Mon Jan 01, 2024 11:40 pm